將MySQL升級成4.1版遇到 ‘Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in …..’ 錯誤訊息要如何解? | jjdai Blog

網址將MySQL升級成4.1版遇到 ‘Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in …..’ 錯誤訊息要如何解? | jjdai Blog 的基本資料:

編號:#2006412

該網頁語系:正體中文

瀏覽數:24H=1, 一週=1, 一月=2

書籤數:16

建立資料時間:2013-08-29 18:46:12

網頁標題: 將MySQL升級成4.1版遇到 ‘Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in …..’ 錯誤訊息要如何解? | jjdai Blog   [ 原網頁 ]

網址: http://jjdai.zhupiter.com/2010/10/將mysql升級成4-1版遇到-warning-mysql_connect-function-mysql-connect-client-does-not-support-authentication-protocol-requested-by-server-consid/

內容快取:     [ 對於本網頁快取的內容,【4a0b 主題快搜】不負任何責任。 ]

將MySQL升級成4.1版遇到 Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in .. 錯誤訊息要如何解? | jjdai Blog jjdai Blog Skip to content 首頁 關於我們 [LINUX]安裝 PHP 時出現undefined reference to `libiconv_open’ 之類的錯誤訊息 安裝 PHP 時出現error: Cannot find MySQL header files under yes的錯誤訊息 將MySQL升級成4.1版遇到 Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in .. 錯誤訊息要如何解? Posted on 2010/10/10 by cctai 之前發表於 http://rental.zhupiter.com/postshow_274_1_1.html 的文章, 重新整理如下: [服務架設][系統]將MySQL升級成4.1版遇到 Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in .. 錯誤訊息要如何解? 錯誤發生的原因是 4.1 版以後的密碼採用新的密碼驗證機制,如果用 myPhpAdmin 去新增出來的使用者,會採用新的機制給予密碼,舊的 mysql client 連進來要驗證密碼時就會出現上述錯誤。 解法: 將該要給舊 mysql client 用的帳號改成舊有的密碼機制,例如用新的 mysql 做以下動作: $ mysql -h new_server_host -u root -p mysql SET PASSWORD FOR some_user@some_host = OLD_PASSWORD(new_password); mysql FLUSH PRIVILEGES; 紅色標示的部分依照自身情況給值。 詳情請看這裡。 你喜歡這篇文章嗎? 馬上分享它:Tweet 無相關文章. This entry was posted in MySQL, 架站, 解決 and tagged myPhpAdmin, MySQL, 架站. Boo... [ 原網頁 ]

將MySQL升級成4.1版遇到 ‘Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in …..’ 錯誤訊息要如何解? | jjdai Blog網址中總共有 16 筆主題資料,以下是 1 - 16  [第 1 頁]。

[將MySQL升級成4.1版遇到 ‘Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in …..’ 錯誤訊息要如何解? | jjdai Blog] 網址相關搜尋產生的主題

consid

網址數: 1

upgrading

網址數: 2

consider

網址數: 2

requested

網址數: 3

does

網址數: 5

authentication

網址數: 8

not

網址數: 34

Warning:

網址數: 3

mysql_connect()

網址數: 2

Client

網址數: 13

MySQL

網址數: 40

support

網址數: 25

server

網址數: 57

by

網址數: 131

protocol

網址數: 4


 |